AMD Investigating USB Issues in 500-Series Motherboards

has launched an investigation into reports of USB problems in its and is asking affected users to sound off on the problem. It’s also invited users to contact it directly by opening a support ticket. The company says it’s engaged in root cause analysis and that some users who post information in the appropriate Reddit thread may be contacted later to provide additional details.

The problem with potential X570 and B550 board stability was indirectly raised by PowerGPU earlier this month. We reported on the PowerGPU situation and the fact that reported RMA rates from other retailers do not match the failure numbers PowerGPU had seen. The company has since taken down its initial tweet and says it is working with AMD to resolve what might have caused its problems. But while there is no public proof that AMD CPUs are failing, AMD X570 and B550 motherboards both seem as though they may have some problematic tendencies. AMD’s Reddit post states:

AMD is aware of reports that a small number of users are experiencing intermittent USB connectivity problems with 500-series chipsets. We have analyzed the cause and at this time would like to ask the community for assistance with a small selection of additional hardware configurations In the next few days, some r / Amd users may be contacted directly by an AMD representative (u / AMDOfficial) through Reddit’s PM system with a request for more information.

Reports in the requisite thread are varied as to the cause and potential solutions. Multiple users are reporting that heavy USB bus activity seems to trigger problems, and VR headsets are commonly mentioned. Other users report that they have to plug USB devices in according to a specific order, or that literally only one port on their motherboard works for VR. I had similar getting an Oculus Rift to function with USB 3.0, but that was years ago, and I was working with an old X79 board with a third-party, first-generation USB 3.0 chip. Modern motherboards, particularly those built for high-end gaming, should be immune to this kind of risk. Other users have reported onboard audio crashes or the failure of third-party DACs when connected via USB.
One potential solution, quoted by multiple users, is to only use PCIe 3.0 signaling speeds for your graphics card. Motherboards should offer the option to use PCIe 3.0 GPU signaling without shutting off PCIe 4.0 SSD support. Some users believe the problem was actually present in the X470 family while others report having previously owned stable X470 rigs before upgrading to either B550 or X570 and that the problems occurred only once they updated.

Sometimes, when you read through a tech thread, you can get a feel for what’s going on and what might fix it. The advice to drop back to PCIe 3.0 definitely works for some people, but not others. One user claims they only encountered the problem on 500-series boards, another person counters that it started with 400-series boards. Some claim issues date back to launch, others have said the problems only began a few months ago. The PCIe 4.0 fix works for a lot of people, but not for everyone. Whether these users are experiencing unrelated USB issues or have a different variant of this common problem is unknown.

One Reddit user, Darklaunch357, reports that deactivating global c-states in UEFI reduces the disconnect rate from every 10 minutes to roughly every 30. He additionally reports:

Update (2/21): After some monitoring and studies, I’ve found that having PCI Express 4.0 enabled leads to high DPC time on “asmtxhci.sys” (ASMedia xHCI Host Controller Driver) according to LatencyMon, and a distinct mistiming leading to high latencies consistently in the 54 ms mark (with eventual spikes to 240-310 ms) as reported by DS4Windows’ latency measurements on a wired DualShock 4. Such spikes coincide with other general malfunctions such as the keyboard freezing and the sound stuttering.

So far, the ONLY reliable workaround is forcibly disabling PCI Express 4.0 by setting PCIEX16_1 to “GEN 3” in the BIOS. The occasional “DRIVER_POWER_STATE_FAILURE” BSOD that may occur every now and then (with a root cause in ntoskrnl.exe) should also be fixed by that workaround.

This is the best summary of the problem as it is understood to date. I’ve recently built myself a system based on a B550 TUF motherboard from Asus, so I’m going to actually try and replicate some workloads on the rig to better test its behavior.

You might also like More from author

Comments are closed.